Compatibility with iOS / Android

To be compatible with iblazr 2 your device should runs iOS 8 or higher/Android 4.3 or higher and have Bluetooth 4.0 option.

Have more questions? Submit a request

Comments

Powered by Zendesk